Oscommerce, recibo el pago pero no el pedido

He podido experimentar problemas con la instalación del SSL en una plataforma Oscommerce. Desde que he instalado el SSL y el modulo Redsys en la plataforma, no me llegan los pedidos realizados por visa pero el pago si que me llega.
Este problema lo he podido solucionar cambiando un parámetro de la configuración del Oscommerce.
Configurations->Sessions_>Force Cookie Use-> False
Si pongo este parámetro en True, la pasarela de pago no me confirma el pedido.

Algunos usuarios con el mismo problema comentan esta solución que no he podido testear aun.

En la configuracion del servidor, como tienes esto: session.use_only_cookies
Dime como lo tienes y si esta en On, haz esto:
Creas un archivo php.ini y le pones esto:

display_errors = Off
date.timezone = “Europe/Madrid”
session.use_only_cookies=Off
suhosin.cookie.cryptua=Off
suhosin.cookie.cryptdocroot=Off
suhosin.session.cryptdocroot=Off
suhosin.session.encrypt=Off

Sube el archivo php.ini a carpeta donde esta la tienda.

<IfModule mod_suphp.c>
SuPHP_ConfigPath /larutacompleta/public_html/catalog/
</IfModule>

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s